DON’T FEED THE TROLL: TALK TO HIM ABOUT LOVE


Jeu réalisé pour l’Adventuron CaveJam (septembre 2019) avec le logiciel Adventuron de Chris Ainsley: https://adventuron.itch.io/
Les graphismes, de 128 x 40 pixels avec une palette de 32 couleurs (Grafxkid), ont été réalisés avec le logiciel GIMP.


This game was made for the Adventuron CaveJam (September 2019) with Chris Ainsley's Adventuron software: https://adventuron.itch.io/

This text adventure game uses a simple verb-noun parser limited to either one- or two-word commands.
You can use the [Tab] key for autocompletion.

English is not my native language.

Verbs to complete the game:
LOOK (L), INVENTORY (I), SCORE
NORTH, SOUTH, EAST, WEST, UP, DOWN (N, S, E, W, U, D)
EAT
EXAMINE (X), READ, SEARCH
FILL, EMPTY
GET, INSERT, DROP, WEAR
GO, ENTER, CLIMB, FOLLOW, SIT
OPEN, UNLOCK
PULL, BLOW, DIG, ROLL, SPANK
SAY
THINK
WAIT
Also provides synonyms.


DEVLOG

Version 1.x (September 2019), Adventuron CaveJam.
Some additional graphical, and spelling corrections (thanks for the help).

Version 2.2.1 Upgrade to Adventuron 1.0.0 Beta 48b, with Bamburgh Font.

Version 2.5.6
Many improvements and fixes.

Comments

Log in with itch.io to leave a comment.

You've got a mismatch in your version. CREDITS says it's version 2.2.0, but ABOUT says it's version 2.2.1. I'm guessing that the latter is correct.

Fixed, but I’m not going to release a new compiled version for this; I have other changes to make.

Hi auraes. I didn't realise that you'd done an update. I was playing the game jam version (v1.0.0) and finished the game with 17 points out of 20. Is it possible to get the full 20 points in that version?

I see from the solution for the new version that you've got some new locations and new puzzles, so now I'll have to give that version a go.

Hi Garry. I’ve been playing the game again recently, because I wanted to put the solution on CASA, and I realized that there are some things wrong: as Adventuron points out in a previous comment, the interaction with the cloud is not clear (BLOW CLOUD); there are also score points that are hard to access (OPEN DOOR, X MOVIE in tower) and other things. I also have the key stuck in the mailbox that should be able to be pushed from inside the cave. I’d also like to make a version with ‘redescribe = auto_beta’, but this requires some changes in the code with the risk of adding new bugs.

I played the new version today, wrote a solution and updated the map for the same reason, i.e. to put a solution on CASA. There were some pretty obscure commands in version 1.0.0 and now there's a bunch of new obscure commands in version 2.2.1. You can finish the game without getting the full score, but it is really, really hard to get the full 15 points. I don't think I would have worked it out without your solution.

Incidentally, I really like the new graphics.

(1 edit)

If it’s too hard, it means the game is bad; I’ll have to review that.
For the graphics, you’re the one complaining about not being able to climb the tree, and get into the tower. I had taken this into consideration even though I have no pleasure in drawing (I do it because it has to be done).
Well, I’m going to have to get my hands into the game code again and again.

The tree is good, but it's not obvious that you can climb further up the tree. I tried CLIMB TREE to climb down and found myself at the top. You can also use UP, but it's not listed as an exit. I guess that's okay if you want to hide it. I did the same thing in 'Seeker of Magic'. The graphics inside the tower and the clearing are really nice. I like the way they change to reflect changes of state.

I also like the way the story develops, particularly the use of the pearl. I sort of missed the meaning of all that the first time around. Stuff like blowing the cloud, a zillion levels beneath the tower and all the teleportation is just downright silly. I still enjoyed the game, though. It's just frustrating.

I will see what I can improve, when I have some time and motivation to do so.

Designing a small text adventure game is a long and winding path full of pitfalls!

All right, thank you. I have made some improvements for this version 2.5.

One item of feedback. The cloud is very significant at the top of the tower, but it is not mentioned in the text. It's generally good practise to make sure that games are playable without graphics (GRAPHICS OFF), so writing something about the cloud would (1) be a clue for the player, and (2) be more accessible for players that play without graphics, or via the screenreading mode.

I had put a hint "Kids, beware of the wind of the storm that takes children away", but it's not clear, and a reference to the cloud is indeed missing in the text.

I've added clues for both clouds.

I got stuck. I thought I had to sit on the throne and "say caw", but it doesn't work.

It says:

"There is no reply."

First, you have to say "say caw" to the raven at the top of the tower.

Now you can type "say caw" without seeing the raven at the top of the tower.

I like this) I've won without using any encoded hints, but got only 5 points xD

This game doesn't have the technical finishes and subtleties of yours. Don't spend too much time on it. It will certainly be better for version 3 (but I doubt that by then my English and technical skills will have improved!)
Have you descended into the depths of the tower (lower levels 1-1001)?

You are underestimating your game. I like it in the current form. But depths - I've realised that there is no 13 level, tried to return, then I was sent up and then no way to try again.

Blow on the cloud, where the raven is... you will reach the lower missing level 13.

Hi, I just learned you updated the game. I'm writing to ask that maybe you can make some hints for the game and base64 encode the answers. See the clues on this page as a baseline. I'm stuck very early on actually, after arriving on the beach a second time (after escaping the lake). I'd love to progress further.

Also, if you ever do publish the source code, I'd be happy to announce it on the Adventuron twitter page, just let me know if you do it.

(1 edit)

The source code is on my GitLab repository (fr) , but it's not exemplary: it's GamJam code and it was my first use of Adventuron.

I'll put hints as you suggest.
Did you get stuck after going into the tower or before?

before. I noticed something was stuck in the letter box too but didn't know how to look at it.

You don't need what's stuck right away, but the memo note might help you.

Amazing little story.  Well done! You also have some talent with the pixel graphics.

Thank you. But this is the game jam version; I'm working on version 2 which should be a little better (coming next week).

Are you expanding or just polishing?

I added a clearing and changed some of the game mechanics. I'm going to put the version 2 code displayed on GitLab, so I'm cleaning up a bit!

Cool, always happy to have a look at the source code for learning. That is the way i started with making text games in my younger years.

Deleted 1 year ago
Deleted 1 year ago

I'm stuck in the tower. found the mecanism, can't find how to pass through the throne. Don't know what to do with the crow.

Ok, found what to do with the crow. Used the torch, i'm stuck out now, with the troll, the fish and the butterfly.

now i'm back on the beach with the shovel, and I don't know what/where to dig.  This story is wierd.

(2 edits)

I'm sorry, but I realize I haven't helped you. I left you with an outdated and developing version.